diff setup.py @ 287:67387621c61b

Added requirements.txt and use it from setup.py
author David Fraser <davidf@sjsoft.com>
date Thu, 05 Sep 2013 16:40:04 +0200
parents 2318792b83c6
children e3ec67b04c03
line wrap: on
line diff
--- a/setup.py	Thu Sep 05 16:16:49 2013 +0200
+++ b/setup.py	Thu Sep 05 16:40:04 2013 +0200
@@ -12,6 +12,14 @@
 except ImportError:
     pass
 
+try:
+    from pip.req import parse_requirements
+    import os
+    install_reqs = parse_requirements(os.path.join(os.path.dirname(__file__), 'requirements.txt'))
+    reqs = [str(ir.req) for ir in install_reqs]
+except ImportError:
+    reqs = []
+
 # This should probably be pulled from constants.py
 VERSION_STR = "0.1a"
 
@@ -64,7 +72,7 @@
     ],
 
     # Dependencies
-    install_requires=[],
+    install_requires=reqs,
 
     # Files
     packages=find_packages(),