diff nagslang/game_object.py @ 558:4abf8cf717e9

Rename "bulkhead" to "hatch".
author Jeremy Thurgood <firxen@gmail.com>
date Sat, 07 Sep 2013 22:09:53 +0200
parents 766472b5c9a6
children 57efcd81647b
line wrap: on
line diff
--- a/nagslang/game_object.py	Sat Sep 07 22:10:12 2013 +0200
+++ b/nagslang/game_object.py	Sat Sep 07 22:09:53 2013 +0200
@@ -480,9 +480,7 @@
                 ("angle", "degrees"), ("key_item", "item name")]
 
 
-class Bulkhead(GameObject):
-    # Yes, I know this should be "hatch" instead of "bulkhead". It was late and
-    # I was tired and the search/replace would touch *everything* now.
+class Hatch(GameObject):
     zorder = ZORDER_FLOOR
 
     def __init__(self, space, end1, end2, key_state=None):
@@ -493,9 +491,9 @@
             puzzler = puzzle.YesPuzzler()
         else:
             puzzler = puzzle.StateProxyPuzzler(key_state)
-        super(Bulkhead, self).__init__(
+        super(Hatch, self).__init__(
             SingleShapePhysicser(space, self.shape),
-            render.BulkheadRenderer(),
+            render.HatchRenderer(),
             puzzler,
         )